Computer Woes

The problem does not happen often but every now and then it happens.  The computer cannot find the boot drive.  Huh!?  Why?  I honestly do not know.  The bios simply forgets that the boot drive is an SSD drive on the SATA3 connections.  It defaults back to one of the Regular HD drives on the SATA2 connections and predictably boot fails since this drive is not a boot drive.  Fairly simple fix…  for me.  When Denise wanted to use the machine she was stuck.  And there was no way I was going to successfully talk her through the procedure to get into the bios and reset the boot drive sequence.  So as a result.  Denise could not use the computer which had her most recent work on it.

This brings me to a bit of a gripe.  The SSD and the HD drives in question are all SATA3 rated.  However the SSD drives simply refuse to work on the SATA2 ports.  I do not know if this is the SSD drive’s fault or if it is something to do with the motherboard’s chipset not knowing how to handle the SSD drive properly.  Initially I was thinking of putting the SSD drive on the SATA2 ports and leaving the HD drive on the SATA3 port.  SSD on a SATA2 port would have been more than fine since all it is really doing is being a boot drive an not much else.  But that plan was scuttled because of the above problem.  So now I get this boot sequence issue every now and then.

I would not doubt it is the motherboard.  I bought it when SATA3 and USB3 was just starting to get popular so it is possible that the chipsets are not 100% with newer drives like the SSD.  However I did not expect the SSD to fail on something that should have been more solid and standard like the SATA2 ports.  All in all, pain in the ass.  Stupid computers.

This is not the first incompatibility I have hit so far.  I have a Thermaltake BlacX5G USB SATA hard drive device.  It does not like dealing with certain hard drives.  I have a HP 1536 multi-function printer, it does not like certain USB ports on the computer.  Lots of frustrating hours lost trying to figure out these problems that really should not have been an issue.

SSD drive is a Samsung 850 EVO, HD drive is a Western Digital WD6402AAEX, Motherboard is an ASUS Sabertooth X58.  ASUS has been pretty good all in all but I have found, when thinking about it, that they have always caused some subtle problems for me.  Nothing ever serious that makes the computer totally unusable or a pain to use but still, minor nigglies that can sometimes annoy.